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HOUSEKEEPING and UTILITIES 

 
 
 
1. System housekeeping 
 
2. Protecting your system 
 
3. Backing up 
 
 
 
 
 
 

WINDOWS UTILITIES 
 

 
MUST HAVE  . . . Anti-virus software  
 

YOU’VE GOT THEM, SO USE THEM Empty the Recycle Bin 
     Scandisk Defrag  Task Scheduler 
 

PROTECTION . . . Antivirus Ad-Aware Spybot S&D 
Firewall – ZoneAlarm  Mailwasher 
SPAMfighter 

 

FILE MANAGEMENT . . FB-Backup WinZip  
Adobe Acrobat Reader 
Word Viewer  Excel Viewer  
Powerpoint Viewer Windows Uninstaller 

 

INTERNET    Google toolbar  SpeedTest 
 

IMAGING AND GRAPHICS  Picasa2   Faststone Resizer 
     Irfanview 
 

GENEALOGY . . . GenViewer  GEDClean GEDmark 
 

 

MISCELLANEOUS . . Parish Locator  WinTree Calisto 
TreePad Lite 

     Passkeeper   
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System  housekeeping 
 
(a)  External ~ 

• Clean the keyboard 
• Clean the screen  -  damp cloth  -meths/water mix 
• Clean CD/DVD reader  -  special disk; cleans reader lens 
• Vacuum air vents  -  in tower case 
• Clean mouse   -  optical  -  mechanical 

 
(b)  Internal ~ 

• Scandisk and defrag the HD 
• Disk cleanup   -  Utility to delete surplus files 
• Delete old files 
• Compress mailboxes after cleaning old e-mails -  OE 
• Uninstall unused programs` -  utilties to do these tasks 
• Keep system patched  -  e.g. Windows Update 

Install and use : 
• Anti-virus    -  resident  ! Updates 
• Firewall    -  e.g. ZoneAlarm 
• Malware software   -  e.g. Spybot; Ad-Awar ! Updates 

 
 
 
Protecting your system 
 
Security Rules 
 
1. Firewalls, anti-virus scanners and spyware detectors require frequent  

updates. 
2. Keep firewall and anti-virus programs running in the background. 
3. Scan all downloaded files for viruses and spyware prior to installation on your  

computer. 
4. Never open an email attachment unless you know the sender and/or are  

expecting the message. 
 
 
 
Backing up 
 
How?  -  use MSBackup or utility (e.g. Fbbackup) 
  -  or Copy/Paste (source � destination) 
  -  Incremental or full backup ? 
 
Where? -  external destination best : (floppy; Zipdisk; CD/DVD; memory stick; external HD). 
 
When? -  once a week?    Month?     (as suits activity). 
 
What?  -  data files (incl. genealogy database) 
  -  Incremental  ….  or full backup? 
             Address book 
             Favourites  (My Documents\bookmarks.htm) 
               Mailboxes 
 
Archiving old/historical files  -  keep up with technology 
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UTILITIES for your Toolbox 
 

 
1.   MUST HAVE 
 
 

Anti-virus software     Reviewed/compared in NZ PC World, May 2006.] 
Absolutely essential if you link to the Internet and/or E-mail.  There are several common 
systems, all about the same in terms of effectiveness : 

1. AVG         http://www.grisoft.com/    Version 8.0 is  free  7/10 
2. Avast! V4.8  http://www.avast.com Version 4.8 is free           not rated 
3. McAfee VirusScan v7.0    http://www.mcafeee.com/     About $80. 9/10 
4. Norton Antivirus 2006      http://www.symantec.com/   About $70. 8/10 
5. Trend Micro PC-cillin       http://www.trendmicro.com/       About $80. 8/10 

Data files (virus signature files) free to download in first year; after that by subscription.  Most updates  are 
automatically downloaded if/when online. 
 
 
2.  YOU’VE GOT THEM, SO USE THEM! 

 
Empty the Recycle Bin 
Double-click on the icon on your desktop.  Select File > Empty the Recycle Bin and press the Enter 
key to delete all files in the Recycle bin. 

 
Scandisk 
Comes with W95 and upwards :  Start > Programs > Accessories  >  System Tools > Scandisk.  A 
scanner to catch and correct physical and logical errors on the hard drive.  Can be used for other 

drives as specified. 
Run weekly, in conjunction with (and just prior to) Defrag.  Check that there are no ‘bad sectors’ on the disk 
surface in the summary panel. 
 

Defrag 
Utility which comes with W95+ : Start > Programs > Accessories > System Tools > Disk 
Defragmenter.   Windows scatters saved files and fragments of files wherever hard disk space 

exists, thus files become fragmented.  A Defragmenter is needed to bring them together again.  Run weekly, 
in conjunction with (and immediately after) Scandisk. 
 

Task Scheduler 
Utility with W98+ :  Start > Programs > Accessories > System Tools > Scheduled Tasks.  Allows 
the user to specify when other utilities (e.g. Scandisk, Defragmenter, anti-virus) are run  -  set by 

date, time and frequency.  Icon often on taskbar. 
 
 
3.  PROTECTION 

 
 Firewall  -  ZoneAlarm   free*   Version 7.0 
Only really needed if you spend extensive time (i.e. several hours per day) on the Internet.  
Zone Lab’s Zone Alarm recommended for ease of use  -  checks incoming and outgoing 

links.   ZoneAlarm v7.0.    http://www.zonelabs.com     Often available on magazine disks. 
 

 
Spyware removal  -  Ad-Aware  free*   Version 2007 
Ad-aware is a free multi-spyware removal utility that scans your computer memory, registry 
and hard drive for known spyware components, and lets you remove them safely. 

Free download from http://www.lavasoftusa.com/  also often available from magazine disks. 
 

 
Spybot Search and Destroy  free*    Version 1.4 
An application to scan for spyware, adware, hijackers and other malicious software.  Download from  
http://spybot.safer-networking-de/   5.6Mb.  also often available on magazine disks. 

 
     NB :  It is useful to have both Ad-Aware and Spybot, since they complement one another. 
 The above 3 are reviewed in NZ PC World July 2004 issue. 
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Beat Spam with Mailwasher      Version 5 
Mailwasher is a freeware program designed to remove spam, viruses and unwanted attachments 
from your email before they get to your computer.    Download trial version of the application from 

http://www.mailwasher.net/    Mailwasher Pro is designed for multiple accounts and Hotmail -  $29.95 from 
http://www.firetrust.com/download/mailwasherpro/ 
 
 

SPAMfighter    free*    Version  
SPAMfighter Standard is a free tool for Outlook and Outlook Express that automatically and 
efficiently filters spam and phishing fraud.  Works with Windows 98, 98SE, 2000, ME and XP.  

From http://www.spamfighter.com/   SPAMfighter Pro costs NZ$47.00. 
 
      free*  =  free to non-commercial users 
 
4.  FILE MANAGEMENT 
. 

 
Freebyte Backup  -  v2.4; free utility which can copy and filter a large number of files and directories 
into one backup directory, and with the advantage of having the ability to do incremental backups 
(i.e., of a certain type; from a specified date, etc.).  Work with W95/98/ME/2000/XP; both from  

http://www.freebyte.com/fbbackup/ 
 

 
Adobe Acrobat Reader       Version 8 
A reader utility to read .pdf files, a common medium for program documentation and help files.  Free; 
from magazine disks, also http://www.adobe.com/acrobat/    Often available where you see the icon 

at right (double-click to download)  :    ��

�

�

Word 97/2000 Viewer     3.9MB 
This is for users who don’t have MS Word; it allows them to open and view Word 97 and Word 2000 
documents.  NB : files opened in this and Excel Viewer are read-only/print-only documents. Users 

cannot edit files, but they can copy information from a document into other applications .   Work with 
W95/98/NT/probably XP.   Freeware.   Also : 
 
 

Excel 97/2000 Viewer     3.9MB 
Allows the user to open and view Excel 97 and Excel 2000 spreadsheet files.  Download both from 
http://office.microsoft.com/downloads/2000/xlviewer.aspx   and   -wd97vwr32.aspx 

 
 
Powerpoint Viewer 97     2.8MB 
Allows the user to open and view Power Point presentations.  A read-only utility. 
Download from  http://office.microsoft.com/downloads/2000/Ppview97.aspx   

 Works with W95/98/NT/probably XP.  Freeware.    
 
 

Windows Uninstaller for adding/removing Windows applications.  Comes with W95+.  It is 
dangerous to uninstall applications via Windows Explorer.  Access from Start > Settings > Control 
Panel > Add/Remove Programs  then locate the application from the options in the window which 

appears. 
 

 
WinZip 
A traditional file compression and decompression utility; now at version 11.  Comes with a 
Wizard to assist use.  Shareware; costs around $US29 to register.  

              http://www.winzip.com/  also often available on magazine disks. 
 

EndItAll2     433KB 
A freeware utility for closing all running programs (including applications running in the background) 
prior to running a program’s set-up routine  -  e.g. installing new software.  It has its place when  • 

installing new software   • uninstalling software   • running other utilties such as Scandisk and Defrag   • 
running memory-demanding games   • writing to CD-R’s that need a big buffer.  A small program, only 
423kb.  Available from  http://home.ptd.net/~don5408/toolbox/enditall/   Freeware; for W95/98/NT/2000/XP. 
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4.   INTERNET 

 
Google Toolbar 
When installed, the Google Toolbar automatically appears under the Internet 
Explorer toolbar : this means you can quickly and easily use Google to search 

from any website location without returning to the Google home page to begin another search.  It is free of 
charge, is multi-lingual. From  http://toolbar.google.com/   Works with W95/98/ME/NT/2000/XP. 
       [See p. 110, NZ PCWorld Dec03/Jan04 for explanation of Google Advanced Search.] 
 
 

Dial up-Broadband Speed test :  test the Download and Upload speed of your internet connection.  
Are you getting what your ISP promised?  Go to  http://nzdsl.co.nz/module-Speedtest.phtml  and 
click on the ‘BEGIN TEST’ button in the centre panel.   

 
 
5.  IMAGING and GRAPHICS 
 
 

Picasa2   Free  5.2MB   Version 2.7 
Image editing software.  Picasa is a free software download from Google that helps you locate and 
organise all the photos on your computer; and to edit and add effects to your photos with a few 

simple clicks.  Share your photos with others through email, prints and on the web : it’s fast, easy and free.  
Requirements – Windows 2000/Me/XP/Vista and Internet Explorer 5.0+ 
Get it from   http://picasa.google.com/ 
 

 
Faststone Resizer  Free  1.4MB   Version 2.5 
FastStone Photo Resizer is an image converter / resizer intended to enable users to convert, 
rename, resize, crop, rotate, change color depth, add text and watermarks to images in a quick and 

easy batch mode. Drag and Drop mouse operation is well supported.  From http://www.faststone.org/   
Works with Windows 98, ME, 2000, XP and Vista 
 

 
  IrFanView   Free  1.1MB   Version 4.1 
IrfanView is a very fast, small, compact and innovative freeware (for non-commercial use) graphic 
viewer for Windows 9x/ME/NT/2000/XP/2003/Vista.   It is simple for beginners and powerful for 

professionals.  From  http://www.irfanview.com/ 
 
 
6.  GENEALOGY 
 

 
GENViewer  Lite    Free    Version 1.13 
A very good utility for viewing the contents of GEDCOM files.  Essential if you are to use GEDCOM 
file exchange a lot.  Reads GEDCOM files; presents summary information; able to print standard 

genealogy charts from the file.    GENViewer 1.18 is shareware with free trial period; about $US20 to 
register.   All versions from  http://www.mudcreek.ca 
 

 
GEDClean32        Version 3.08 
A useful utility designed to clean a GEDCOM file to exclude details about living individuals.  
Shareware; From http://www.raynorshyn.com/gedclean/  ; GEDClean32 v 3.08; $US9.95,  

about $NZ20.00.  
 

 
GEDmark        Version 1.0.1 
Utility which works with GEDCOM files by adding a new source citation to each record containing 
information about the person who created the GEDCOM file (e.g. name, address, etc.) – thus 

marking the genealogical records with the author’s information.  Disables the practice of others to take your 
work and claim it as their own.  Works with W95/98/ME/NT/2000/XP.  $US9.95; obtain from  
http://www.progenygenealogy.com/ 
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TreePad Lite   Freeware  465KB  Version 2.9.5 
TreePad is an award-winning personal information manager, database and word processor, 
featuring portability and compactness, simplicity and intuitiveness of use.  There are several 

versions : TreePad Lite is freeware.  Can be used as a website generator.  Useful for keeping notes, 
documents, hyperlinks and images a click away.  V2.9.4 for Windows; from  http://www.treepad.com/ 
 
 
6.  OTHER 
 
 

Parish Locator  Freeware  662KB   Version 2.7 
Good example of a genealogy utility.  A finding aid to locate parishes in England and Scotland 
between the 1500’s and 1837.  Database of 150,000 parishes.  It will also list parishes within a given 

radius of any other parish.  Freeware; for W95/98/NT/2000/XP.     
http://www.parloc.pwp.blueyonder.co.uk/ 
 

 
WinTree  Shareware  673KB    Version 4.21 
An easy-to-use genealogy chart program which produces several different charts (ancestors and 
descendants) from your database in GEDCOM format.   Version 4.21; for W95/98/ME/ XP. From  

http://website.lineone.net/~d.j.cooke/wintree.htm 
 
 

Calisto Calendar Utility   Freeware   Version 3 
Displays the English calendar from AD326 to 2999.  Also shows Easter and movable feasts, English 

monarchs, English regnal years, old style calendars.  Print facility.  Windows 95/98/NT/XP. From  
http://homepages.tesco.net/~jk.calisto/calisto/ 
 

 
Passkeeper  Freeware  87KB  Version 1.2 
Utility for storing a list of accounts with usernames, passwords and notes.  The file is    

  encrypted on exiting the application.  NB: requires a password to access the program : if the access 
password is lost, forgotten or corrupted, the list cannot be recovered.  Windows 95 and later. 
From  http://www.passkeeper.com/ 
 
 

 


